1. Для обновления шаблона необходимо оплатить услугу Техническая поддержка (500 руб. - Яндекс-деньги или банковский перевод) модуль справа-внизу, сообщить admin_forum e-mail на который будет выслана актуальная версия шаблона или расширения
    Скрыть объявление

Возникла проблема в работе модуля News PRO GK5 с собственным форматом статьи

Тема в разделе "News Show Pro GK5", создана пользователем Light_And_Dark, 23 фев 2014.

  1. Light_And_Dark
    Оффлайн

    Light_And_Dark Новичок

    На сайте //test.haircolor.org.ua/ я при работе использую многократно данный модуль, но с толкнулась с проблемой. Все ссылки корректно загружаются при работе модуля, если я не использую собственный формат статьи. Но у меня есть несколько вариаций загрузки модуля с собственным форматом статьи (модули в виде табов популярное, рекомендуем и последние), а так же модуль - Последние ингредиенты. Вот тут то и возникла проблема: на переменную {URL} вместо подстановки ссылки на странницу с материалом k2 мне система подставляет ссылку на категорию, а переменную {CATEGORY_URL} - она вообще ничем не заполняет. Я использую модуль самой последней версии и ничего в самом модуле не меняла. Подскажите где можно исправить данную ошибку. Все остальные данный кроме url и category_url система подставляет корректно.
    Использую модуль самой последней версии на joomla 2.5. k2 то же последней версии.
     
  2. Елена Пта
    Оффлайн

    Елена Пта Модератор

    Что-то вы с настройками модуля намудрили
     
  3. admin_forum
    Оффлайн

    admin_forum Администратор

    На демо сайте всё отражается корректно, ссылки ведут на статью, а в коде страницы у вас, все ссылки ведут на категорию
    Для более детального анализа прикрепите скрин настроек модуля
     
  4. Light_And_Dark
    Оффлайн

    Light_And_Dark Новичок

    На демо сайте используется другие модули созданные smartaddons для материалов joomla. Я их внешний вид воссоздавала с помощью news show pro для статей k2.
    Перед тем как скинуть скриншоты хочу обратить внимание, что если выключаю функцию использовать собственный формат при тех же настройках - нарушается вся красивая верстка, но... при этом ссылки работают корректно. Но включение собственного формата - ломает все.
    [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG]
    [​IMG] [​IMG]
    Еще такой вопрос не могут ли быть подобные глюки из-за того что я обновляю модуль через обновление joomla а не заменяю его? Изначальна стояла какая-то другая версия, но я ее по мере выхода обновлений регулярно обновляю.
    Я на сайте //test.haircolor.org.ua вывела один и тот же модуль но со включенными и выключенными собственными настройками вывода статей.
    А вот так выглядит самописный формат модуля:
    Код:
    <div class="item post">
        <div class="post-inner">
              <div class="news-image">
                      <img src="{IMAGE_SRC}" alt="{TITLE}"    />              
                <div class="image-overlay">
                    <div class="hover-links clearfix">
                        <a class="hover-zoom" data-rel="prettyPhoto" title="{TITLE}" href="{IMAGE_SRC}"><i class="icon-external-link"></i></a>
                        <a class="hover-link" href="{URL}" title="{TITLE}"><i class="icon-plus"></i></a>
                    </div>
                </div>
              </div>
            <h2 class="news-wrap">
                <i class="icon-add"></i>
                <a title="{TITLE}" href="{URL}">{TITLE}</a>
            </h2>
        </div>
    </div>
    В сам модуль я правок не вносила, но скопировала содержимое папки tmpl в шаблон и внесла некоторые исправления в отображения картинок в материалах k2. Что бы над картинками появились всплывающие ярлычки. Более никаких правок я не делала. Может стоит удалить модуль и установить его заново?
     
    Последнее редактирование: 27 фев 2014
  5. admin_forum
    Оффлайн

    admin_forum Администратор

    Гавики рекомендуют переустанавливать модуль, в принципе мы при выкладывании новой версии всегда это подчёркиваем
    Второй момент, перед внесением правок в код, сначала настройте его желаемое отражение до правок, что бы не ломать голову в поиске и выборе нескольких возможных причин ошибки
    Да и SmartAddons как и любой сторонний производитель слегка меняют стиль подгоняя под свой дизайн, но на сейчас ошибок на сайте вроде нет или вы выключили настройки...
     
  6. Light_And_Dark
    Оффлайн

    Light_And_Dark Новичок

    Сейчас за загружаются 2 одинкаковых модуля Последние ингредиенты и Последние ингредиенты 2 первый со включенными настройками, а второй без. Так как тот что со включенными настроками так нормально не работает. А второй не красиво грузится, но зато ссылки корректные. Так же и табы - в них ссылки работают не корректно. Формирует ссылки для табов как раз News Pro GK5, а отображает табами их другой модуль. Так вот формирование то же не корректное.
    Что до правок. Дело в том, что еще до внесения правок в шаблон отображения модуля ссылки не работали. Мне кажется что ранее модуль работал корректно. Что до правок SmartAddons. По умолчанию у них k2 нет и его я ставила чистым и меняла только шаблон отображения все остальные фаилы самого k2 не изменны.
    Модуль переустановила заново, но перенесла настройки через БД - проблема так и осталась.

    Попробовала следующий вариант. Скачала чистую joomla 2.5 с сайта joomla.ru установила на хостинг с демо данными. Поставила читый самы последний k2 и импортировала демо данные joomla в k2. И установила модуль новостей. Все настрокий оставила модуля по умолчанию кроме того что скинула собственные форматы вывода статей и подключила их и настроила на взятия статей с k2, а именно все статьи k2 по дате. Все остальные настройки не меняла. Вот результат //hc.esy.es/ - модуль не работает корректно. Вместо того, что бы перебрасывать на статью - сбрасывает на категорию. Есть варианты почему? Я все брала с официальных сайтов и скачивала сегодня, т.е. все стандартное. Могу дать логин и пароль от адимин панели, если нужно что бы могли посмотреть на то что там. Формат статьи использовала тот что был приведен ранее - никаких изменений в него не вносилось.
     
    Последнее редактирование: 5 мар 2014
  7. Елена Пта
    Оффлайн

    Елена Пта Модератор

    Сегодня будет выложена новая версия модуля, гляньте что там изменили
     
  8. Light_And_Dark
    Оффлайн

    Light_And_Dark Новичок

    Удалила модуль и установила его заново вот сюда //hc.esy.es/ те же настройки по умолчанию модуля, тот же шаблон вывода и подхватывание статей с k2. Результат: модуль опять перебрасывает на страницу категории, а не на статью. К сожалению, моя проблема не решена.
     
  9. admin_forum
    Оффлайн

    admin_forum Администратор

    На следующей недели буду делать сайт с использованием этого модуля, обращу внимание на настройки и отпишусь в теме
     
  10. Light_And_Dark
    Оффлайн

    Light_And_Dark Новичок

    Было бы не плохо.
     
  11. Light_And_Dark
    Оффлайн

    Light_And_Dark Новичок

    Ну как пробовали настройки модуля?
     
  12. admin_forum
    Оффлайн

    admin_forum Администратор

    Не ваша ли проблема описана в новой версии:
     
  13. Light_And_Dark
    Оффлайн

    Light_And_Dark Новичок

    Да моя. Пришлось писать на пару с гугл-переводчиком на официальный форум гавиков, что бы они пофиксили в новой версии модуля. Теперь даже просто после обновления, а не полной переустановки модуля проблема решается.
     
    Елена Пта нравится это.

Поделиться этой страницей